
 

 

 

 

 

 

Welcome to NX 

 

August 2019 

Dear Customer:  

We are proud to introduce the latest release of our product development solution. With this 

release, we continue to provide innovative ways to deliver solutions that meet the next generation 

of your product design, development, and manufacturing challenges. The new version of NX is 

robust and powerful, and it delivers advanced technologies for product design, development, and 

manufacturing in a single, multidisciplinary platform. It preserves best-in-class customer 

deployment readiness, and builds on the productivity and stability achievements of the previous 

release.  

 

Sincerely, your NX Release Team 
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NX 1867.4400 
 

1867.4400 UPDATES 
 

NX Automatic Update 

Automatic updates will not be available for releases on NX 1847 Series after NX 1867, including NX 

1867.4400. Users who are on 1867 with automatic update option turned on will be notified to download 

and install the 1872 release. If 1867.4400 is preferred, users must download the release from the GTAC 

Download Server. 

 

1867.4400 PROBLEM REPORTS 
 

For a detailed list of PR fixes, see Fixed_Problem_Reports.csv included with the release documents. 

Please see the table below for a summary of the PR updates included in this release. 

Application Count of PR Number 

ASSEMBLIES 3 

CAE 2 

CAM 8 

DESIGN 1 

DRAFTING 6 

GATEWAY 1 

KDA 4 

NXMANAGER 3 

ROUTING_ELEC 1 

ROUTING_MECH 1 

SYSENG 3 

TRANSLATOR 7 

Total 40 
 

1867.4400 ENHANCEMENTS 

 
No ERs were included in this update. 

 

 
 



NX 1867.4100 
 

1867.4100 UPDATES 
 

NX Automatic Update 

Automatic updates will not be available for releases on NX 1847 Series after NX 1867, including NX 

1867.4100. Users who are on 1867 with automatic update option turned on will be notified to download 

and install the 1872 release. If 1867.4100 is preferred, users must download the release from the GTAC 

Download Server. 

 

1867.4100 PROBLEM REPORTS 
 

For a detailed list of PR fixes, see Fixed_Problem_Reports.csv included with the release documents. 

Please see the table below for a summary of the PR updates included in this release. 

Application Count of PR Number 

ASSEMBLIES 8 

ROUTING_GENERAL 5 

DRAFTING 3 

PMI 1 

NXMANAGER 1 

Total 18 
 

1867.4100 ENHANCEMENTS 

 
No ERs were included in this update. 

  



NX 1867 
 

1867 UPDATES 
 

NX Automatic Update 

Automatic updates will be available for the NX 1867 release and onwards. Users who are on 1867 with 

automatic update option turned on will be notified to download and install the 1872 release. 

 

1867 PROBLEM REPORTS 
 

For a detailed list of PR fixes, see Fixed_Problem_Reports.csv included with the release documents. 

Please see the table below for a summary of the PR updates included in this release.] 

Application Count of PR Number 

NX_SHEET_METAL 10 

CAM 9 

SHIP_DESIGN 4 

CAE 3 

GATEWAY 3 

NXMANAGER 3 

PMI 3 

ASSEMBLIES 2 

DESIGN 2 

TRANSLATOR 2 

CMM_INSPECTION 1 

ROUTING_ELEC 1 

ROUTING_GENERAL 1 

TC_FEATURES 1 

Total 45 

 

1867 ENHANCEMENTS 

 
No ERs were included in this update. 
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Routing PLMXML Export/Import 
 

 

Introduction  

We have added the capabilities to explicitly export/import Routing electrical connector/connection data 

to/from various datasets under an Item Revision in Teamcenter.  The dataset type, the dataset relation, 

and named reference type are all configurable via the Routing electrical preferences in the appview file.  

In previous versions of NX, it was only possible to export Routing electrical connector/connection data to 

a dataset named “Routing Electrical Data” under an Item Revision as it was being saved.  Also, it was only 

possible to import the Routing electrical connection/connection data from this pre-defined dataset 

named if it had been saved with the Item Revision.  

Configuration  

The user can configure the dataset type and dataset relation to the item revision through the 

“Electrical_Preferences” section of the electrical appview file, like in the example below:  

<PLMXML_DATASET_TYPE> 

NX Routing  

</PLMXML_DATASET_TYPE>  

  

Similarly, the relation that the dataset has with the item revision is specified like:  

<PLMXML_DATASET_RELATION> 

IMAN_manifestation  

</PLMXML_DATASET_RELATION>  

  

And the named reference type can be specified as:  

<PLMXML_NAMED_REFERENCE_TYPE>       

 NXRoutPlmXml  

</ PLMXML_NAMED_REFERENCE_TYPE >  

  

From NX1872 onward, the existing functionality to automatically export PLMXML on save will use the 

above settings as well, though the name of the dataset and named reference will remain as is.  



Command Location 

The commands to export/import the connection/connector data to/from an Item Revision will be 

available under the existing commands available from the Component Navigator and Connection 

Navigator  

1. RMB->”Export to PDM”  

2. RMB->”Import from PDM”  

Currently, “Export to PDM” is only available if there is at least one component in the component navigator 

or at least one connection in the connection navigator. It will be greyed out on the RMB menu options on 

the Connection/Component Navigators if there is no data to export.    

It will also be available from the main menu:  

• Tools -> Connection List -> Import from PDM System 

• Tools -> Connection List -> Export to PDM System 

• Tools -> Component List -> Import from PDM System  

• Tools -> Component List -> Export to PDM System  

If invoked from the Connection List or Component List menus on the main menu toolbar, it will never be 

greyed out, but a warning dialog will popup stating “Routing: Part file contains no electrical data” and it 

will then immediately exit the command.  

Usage 

When the “Import from PDM” command is invoked, the following dialog appears:  

  

Within this dialog, you specify the inputs to import a PLMXML file with connection/connector data into 

the current NX routing session.  The inputs are:  

1. The dataset and its associated item/revision in Teamcenter from which the data is being 

imported from  

2. The import mode, Update/Merge/Append.  



The import mode behavior is as follows:   

• Append: adds all the connections and/or connectors imported to the existing set of connections 

and/or connectors in the session.  It creates new connectors and/or connections for each 

connector and/or connection imported.  

• Merge: maps any imported connections and/or connectors imported to the existing set of 

connections and/or connectors in the session.  This option will create any connections and/or 

connectors that don’t exist in the session and map the imported connectors and/or connections 

to either existing connectors and/or connections or the newly created one. 

• Update: overwrites any matching connections and/or connectors in the session with the imported 

connections and/or connectors that match.  It will create any connections and/or connectors that 

don’t exist in the session as needed.  

  

When the “Export to PDM” command is invoked, the following dialog appears:  

  

Within this dialog, you specify the inputs to export a PLMXML file with connection/connector data into 

the dataset of an item/revision in Teamcenter.  The inputs are:  

1. If you are overwriting and “Existing Netlist” dataset or creating a “New Netlist” dataset on the 

item/revision to be exported to 

2. The item/revision to create the dataset on OR to overwrite an existing dataset for  

3. The name of the new dataset to create on the item/revision OR the name of the existing 

dataset on the item/revision to overwrite  

Reverting to Old Behavior 

If the user desires to maintain the old behavior under the existing commands, the user needs to set the 

environment variable “UGII_ROUTING_OLD_PDM_EXCHANGE=1”.   With this environmental variable set, 

the above mentioned commands will take their old forms, and the new commands will be named “Export 

PLMXML to Teamcenter” and “Import PLMXML from Teamcenter”.    

  



NX 1863 
 

1863 UPDATES 
 

NX Automatic Update 

Automatic updates will be available for the NX 1863 release and onwards. 

 

1863 PROBLEM REPORTS 
 

For a detailed list of PR fixes, see Fixed_Problem_Reports.csv included with the release documents. 

Please see the table below for a summary of the PR updates included in this release. 

Application Count of PR Number 

ASSEMBLIES 10 

CAE 9 

CAM 9 

SYSENG 6 

KDA 5 

DRAFTING 5 

ROUTING_GENERAL 4 

ADD_FIXED_PLANE 4 

DESIGN 3 

NXMANAGER 3 

NASTRAN 2 

SHIP_DESIGN 1 

CORRUPTED_PARTS 1 

DMU 1 

Total 63 
 

1863 ENHANCEMENTS 

 
No ERs were included in this update. 

 

 

  



NX 1859 
 

1859 UPDATES 
 

NX Automatic Update 

The issue where the NX Automatic Update feature did not have NX 1855 available for download is 

addressed in NX 1859. Automatic updates will be available for the NX 1863 release and onwards. 

Teamcenter 

The issue where the Associate to NX and Disassociate from NX buttons are not available in the Active 

Workspace web client in NX is addressed in NX 1859. When NX is integrated with Teamcenter 11.6, 

the Associate to NX and Disassociate from NX buttons are available in the Active Workspace web client in 

NX by setting the PLE_AnalysisRequest_CopyAttribute preference in Teamcenter.  

 

1859 PROBLEM REPORTS 
 

For a detailed list of PR fixes, see Fixed_Problem_Reports.csv included with the release documents. 

Please see the table below for a summary of the PR updates included in this release. 

Application Count of PR Number 

SYSENG 11 

CAM 9 

ASSEMBLIES 8 

NXMANAGER 6 

ROUTING_GENERAL 6 

CAE 4 

DESIGN 3 

MECHATRONICS 2 

GATEWAY 2 

KDA 1 

NX_SHEET_METAL 1 

DRAFTING 1 

CMM_INSPECTION 1 

ROUTING_ELEC 1 

Total 56 
 

1859 ENHANCEMENTS 

 
No ERs were included in this update. 



NX 1855  
 

1855 UPDATES 
 

1855 PROBLEM REPORTS 
 

For a detailed list of PR fixes, see Fixed_Problem_Reports.csv included with the release documents. 

Please see the table below for a summary of the PR updates included in this release. 

Application Count of PR Number 

CAM 20 

DESIGN 7 

ROUTING_ELEC 4 

ROUTING_GENERAL 3 

ROUTING_MECH 2 

CAE 2 

ASSEMBLIES 2 

STUDIO_DESIGN 1 

SYSENG 1 

DRAFTING 1 

Total 43 
 

1855 ENHANCEMENTS 

 
No ERs were included in this update.  



NX 1851  
 

1851 UPDATES 
 

SFB-NX-8007909 

The issue where NXGateway.exe was falsely flagged by a few virus checkers in NX 1847 is addressed in NX 

1851. 

The fix addresses the issue with the virus checker and also renames the utility to Siemens Cloud Connector 

Service, i.e., SccS.exe. After you download the MU, the NX MSI installer will remove the old executable 

and replace it with the new executable.  

NX18XX CATIAV5 Translator Caveat 

NX File->Open and File->Import of Catia V5 files (*.CATProduct and *.CATPart) will contain no geometry 

if the Current directory (as seen in the system log file) is an unwritable directory. The recommended 

temporary work around is to set the environment variable SCA_TMP_DIR to a writable directory prior to 

starting NX. 

 

1851 PROBLEM REPORTS 

 
For a detailed list of PR fixes, see Fixed_Problem_Reportss.csv included with the release documents. 

Please see the table below for a summary of the PR updates included in this release. 

Application Count of PR Number 

NX_SHEET_METAL 9 

DESIGN 8 

CAM 7 

SYSENG 5 

MFG_LINE_DESIG 4 

ASSEMBLIES 4 

CLASSIFICATION 3 

ROUTING_GENERAL 3 

CAE 3 

ROUTING_ELEC 2 

NXMANAGER 2 

CMM_INSPECTION 2 

GATEWAY 2 

KDA 1 

ADV_SHEET_METAL 1 

DRAFTING 1 

Total 57 

https://solutions.industrysoftware.automation.siemens.com/view.php?si=sfb-nx-8007909


1851 ENHANCEMENTS 

 
Please see below for a list of enhancements included in this release. 

ERs 

• 8395265 - Fixed Unfolded Length Type for Resize Bend Radius changes geometry of the part 


