Designing in the context of an assembly
Proprietary and restricted rights notice

This software and related documentation are proprietary to Siemens Product Lifecycle Management Software Inc.

© 2017 Siemens Product Lifecycle Management Software Inc.
Contents

Proprietary and restricted rights notice ................................................................. 2
Course introduction ................................................................................................. 1-1
Top-down and bottom-up design in Solid Edge ...................................................... 2-1
Transferring and Dispersing Assemblies ............................................................... 3-1
Restructuring assemblies ....................................................................................... 4-1
Activity: Transferring and dispersing in assembly ................................................ 5-1

Activity: Transferring and dispersing assemblies .................................................. 5-2
Open the assembly .................................................................................................... 5-3
Examine the assembly structure .............................................................................. 5-4
Disperse one of the subassemblies ......................................................................... 5-5
Examine the results of the disperse command ...................................................... 5-7
Transfer parts into a subassembly .......................................................................... 5-8
Summary ................................................................................................................... 5-11

Lesson review .......................................................................................................... 6-1

Lesson summary ....................................................................................................... 7-1

Inter-Part ................................................................................................................... 8-1

Inter-Part associativity ............................................................................................... 9-1

Activity: Inter-part assembly modeling .................................................................... 10-1

Activity: Inter-Part assembly modeling .................................................................... 10-2
Create a new assembly file and set the parameters for Inter-Part .......................... 10-3
Create a new part in-place ....................................................................................... 10-4
Insert an Inter-Part Copy that will be used as a construction surface to create a sheet metal cover ........................................................... 10-6
Use the Contour Flange command to construct the sheet metal cover .................. 10-8
Place a cutout and four holes on the top face of the cover linked via Inter-part ...... 10-11
Place four holes on the cover using the inter-part copied faces as reference ......... 10-12
Add a cutout to the cover ....................................................................................... 10-15
Turn on the display of Chassis.psm and then return to the assembly file ............... 10-17
Make an edit and update the links to update the new sheet metal cover ............... 10-18
Activity Summary ................................................................................................. 10-20

Lesson review .......................................................................................................... 11-1
Lesson summary ......................................................... 12-1

Assembly layouts ....................................................... 13-1

Assembly layout overview ........................................... 14-1

Activity: Creating parts from Assembly Sketches ............. 15-1

Activity: Layout sketches in assembly ................................ 15-2
Set associativity parameters ........................................... 15-3
Create a part that is the front half of the radio housing .... 15-4
Construct an extrusion .................................................. 15-5
Add a round ............................................................... 15-8
Apply a thickness to the part ........................................... 15-9
Add cutouts ............................................................... 15-10
Create the back half of the radio housing ......... 15-14
Construct a protrusion using the assembly sketch ........ 15-15
Add a cutout to the part ................................................. 15-18
Thin wall the part ....................................................... 15-21
Add another cutout ...................................................... 15-22
Edit the assembly sketch and observe changes ........... 15-25
Repeat the previous step .............................................. 15-27
Link the wall thickness to the two parts .................. 15-28
Activity summary .................................................... 15-31

Lesson review ........................................................... 16-1

Lesson summary ........................................................ 17-1
Lesson 1: Course introduction

Welcome to Solid Edge self-paced training. This course is designed to educate you in the use of Solid Edge. The course is self-paced and contains instruction followed by activities.

Start with the tutorials

Self-paced training begins where tutorials end. Tutorials are the quickest way for you to become familiar with the basics of using Solid Edge. If you do not have any experience with Solid Edge, please start by working through the basic part modeling and editing tutorials before starting self-paced training.

Tutorials

Adobe Flash Player required for videos and simulations

To watch videos and simulations, you must have the Adobe Flash Player version 10 or later installed as a plug-in to your browser. You can download the Flash Player (free) at the http://get.adobe.com/flashplayer
Lesson 2: Top-down and bottom-up design in Solid Edge

Mechanical design and engineering requires careful planning and an analytical approach to developing new products. The purpose of CAD/CAE/CAM is to reduce the design cycle length, and eliminate fit errors by taking better advantage of common part geometry. When designing assemblies using computer-aided design tools, there are two basic ways of categorizing assembly design: top-down design and bottom-up design.

Top-down assembly modeling

Top-down assembly modeling is an assembly-centric modeling method where the assembly design is started at the highest level possible, and individual parts and subassemblies are defined within the context of the overall assembly. With this approach, an assembly layout is typically created first, and this assembly layout is used to define individual part geometry and position.

This approach is often used at companies where the product being designed is large enough that it requires many people to complete the design. A senior-level designer might create the initial assembly layout, then divide the assembly layout into logical subassemblies and parts for the remainder of the organization to complete.

Bottom-up assembly modeling

Bottom-up assembly modeling is a part-centric modeling method where the assembly design is started with a principal structural or functional element, and individual parts are designed in relative isolation from the overall assembly. Component parts and subassemblies are defined as the process moves up towards the top-level assembly. With this approach, as the design of a key component is completed, its geometry may or may not be used to aid the design of related mating components.

This approach is often used at companies where the product being designed is small enough that one or only a few people are needed to complete the design.

Combining both approaches

Solid Edge provides tools that allow you to take advantage of the benefits of both approaches as needed. Many organizations use a combination of both methods, using the method which best suits the immediate requirements. For example, you can use the top-down approach to create the initial assembly layout and to define the document structure needed. You can then copy the assembly layout geometry to subassembly and part documents to divide the work among the organization.

You can shift to the bottom-up approach in areas of the design that use purchased parts, existing parts from an earlier project, or where you are modeling standard parts in 3D that were created on an earlier 2D CAD system.

The suite of commands and tools in Solid Edge also allow you to use either approach associatively or nonassociatively, as you see fit.
**Top-down tools**

The primary top-down assembly design tool within Solid Edge is virtual component modeling, available in the Assembly environment. The Creating and Publishing Virtual Components Help topic discusses this functionality in depth.

If you choose not to use virtual component modeling, you can use the Copy Sketch command to copy layout graphics to parts and subassemblies, either associatively or nonassociatively.

The **Create In-Place** command allows you to create new parts associatively or nonassociatively within the context of the assembly. The Constructing New Parts within an Assembly Help topic discusses this functionality.

Assembly-based features allow the creation of features within assembly components without having to in-place activate the component. These features can either reside at the component level, or exist only at the assembly level.

You can control whether the new parts are associative to existing parts using the suite of Inter-Part Associativity tools available. The options on the Inter-Part tab on the Options dialog box allow you to control what types of associatively you want to use.

**Assembly Features** allow for the creation of features from the assembly level that can either exist only in the assembly, or be pushed down into the parts. Through dynamic editing, dimensions to parts can be seen and edited at the assembly level without in-place activation of the parts.

The Project to Sketch command also allows you to associatively or nonassociatively copy geometry between documents when working in the context of an assembly.

Many feature commands allow you to define the extent of the feature associatively by selecting a keypoint on another part in the assembly.
Bottom-up tools

With the bottom-up approach, you can create new 3D models in relative isolation from the assembly by referencing existing paper or electronic drawings, or by designing entirely new components.

A variation of the bottom-up approach involves using the Part Copy command on the Insert menu to associatively or nonassociatively copy surface geometry from one 3D model to another 3D model outside the context of an assembly. This approach is especially useful when working with tightly related components that share common characteristics, such as parts that make up an weldment assembly.

When used associatively, the Part Copy command allows you to control common geometry on several child parts from one or more parent parts. You can edit the parent document, then open and update the child documents without creating or referencing an assembly document.

When used nonassociatively, part copies allow you to quickly reuse existing geometry in another document.

Bringing it together

With either approach, you usually will want to view the components within one or more assemblies. You can use assembly relationships to position the components in the assembly, or you can use coordinate systems to define the position of each component in the assembly structure.
Lesson 3: Transferring and Dispersing Assemblies

The ability to transfer and create subassemblies within the tree structure of an assembly or to push the parts out of a subassembly into a higher level assembly is a powerful tool when managing and manipulating large assemblies.
Lesson 4: Restructuring assemblies

Solid Edge contains commands that allow you to change the structure of an existing assembly.

The **Transfer** command transfers parts and subassemblies from one assembly to another. You can transfer these parts and subassemblies to any level of the assembly that can be seen from the top-level assembly that is open. You can also use the **Create New Subassembly** dialog box to create a new subassembly for the transferred files. To access the **Create New Subassembly** dialog box, on the **Transfer to Assembly Level** dialog box, click the **New Subassembly** button.

The **Disperse** command transfers the parts in a subassembly to the next highest subassembly and deletes the reference to the subassembly. The command disperses only the top-level occurrence of a subassembly. For example, if a subassembly exists as an occurrence within the assembly being dispersed, the subassembly remains unchanged, but is moved up to the next higher assembly level.

To change the order of the files within an assembly, you can drag and drop parts in the **PathFinder**.

**Transferring parts between assemblies**

You can use the **Transfer** command to transfer assembly files, parts containing **Inter-Part** relationships, tube parts, and pattern parts. It is important that you understand how Solid Edge handles these transfers so you can avoid possible problems.

When transferring parts, it is very important that you have write access to all of the part and assembly files involved in the transfer.

Solid Edge handles relationships during transfers just like it would if you deleted a part from one subassembly and added it to another. It attempts to re-establish each positioning relationship exactly like it was before the transfer, with reference to the same reference part. If the reference part remains in the assembly tree below its new location, the relationship should be successfully re-established. If the reference part is not below the transferred part's new location, it will not be converted into a non-positioning relationship and the relationship is removed. You will not receive warnings for affected relationships during transfers, so you should be very careful when transferring parts with relationships. You might choose to add positioning relationships to any occurrence that becomes underconstrained after its transfer.

If you transfer a part that is a parent of an **Inter-Part** relationship, the link is broken, but not deleted. **Inter-part Manager** will show the **Inter-Part** link as broken, just as if the parent part was deleted from the assembly. You will not receive a warning when the parent part is deleted. You must understand the relationship dependencies within your assembly so that you can avoid breaking links when you transfer parts. You will be warned if you transfer a part that is **Inter-Part** child. If you continue with the transfer, the link will be broken and automatically deleted by the command.

Pasted variable links will remain intact during transfer as long as both the parent and child remain anywhere in the assembly.

If you transfer a tube part containing the port that defines a path, the link will be deleted and you will not receive a warning message. If you transfer a part containing a port to a level above the assembly containing the tube path, the tube path becomes nonassociative to the part and you will not receive a warning message.
If you transfer a part containing a feature pattern that drives the assembly pattern, the pattern disappears and you not receive a warning message.

**Transferring parts to a new subassembly**

Solid Edge allows you to create a new subassembly for parts you want to transfer. The **New Subassembly** button on the **Transfer to Assembly Level** dialog box accesses the **Create New Subassembly** dialog box. You can use this dialog box to specify a template, file name and location for the new database. You can also use the dialog box to define the position of the transferred parts in the new subassembly.

You have two options when defining the part position.

- **Position First Selected Part at Origin** and **Others Relative to It**
- **Maintain Current Offsets From Assembly Origin**

The first option specifies that if the new subassembly is opened outside of the parent assembly, the parts will be positioned relative to the global reference planes so that when you fit the view, the parts will not be remote from the reference planes. This option provides results similar to creating a new assembly with existing parts. For example, when you create a new assembly and drag the first part in from **Parts Library**, it is grounded at the origin of the assembly file. The subassembly is then positioned as a whole within the upper-level assembly.

The second option specifies that you want to position everything relative to a single global origin. After the new subassembly is created, if you open the subassembly outside of the parent assembly and the fit the view, the parts might be remotely located from the global reference planes.

**Transferring part occurrences between subassemblies**

If you transfer a part from one subassembly to another and there are multiple occurrences of one or both of the subassemblies within the assembly structure, it is very likely that the instances of the transferred occurrence will change. For example, if a part in subassembly A, which occurs only once, is transferred into subassembly B that occurs five times, the effect is that four instances of the transferred occurrence is added. Likewise, if there are more occurrences of the source subassembly than there are of the target subassembly, the number of occurrences instead could be reduced.

**Things to consider when transferring parts**

There are several things you need to consider when transferring parts. It is important that you understand how Solid Edge handles these situations so you get the desired results from your transfer.

- **Occurrence numbers**

  The occurrence number of a occurrence after its transfer into the target assembly is the next consecutive number available for the file name that is transferred. If you transfer more than one of the same file name occurrences at the same time, the number that is assigned to each occurrence in the target assembly is determined by the order in which they are numbered in the source assembly.

- **Display configurations**

  Existing **Display Configurations** become invalid as parts are removed or added during part transfer.
Face styles of transferred parts
If you transfer a part into a target assembly that contains a style that is assigned to the part in the source assembly, you must reapply the style after the transfer. If the target assembly does not contain the style assigned to the part in the source assembly, the part is assigned the Aluminum style.

Explode configurations
Explode Configurations become invalid as parts are removed or added during part transfer. In the Draft environment, drawing views will go out-of-date when parts are removed or added from the configuration.

Groups
Groups are not maintained during part transfer. Solid Edge handles the transfer of groups the same as if the part was manually deleted from or added to the source assembly.

3D section views
Since 3D section views contain a list of parts that are cut, they are affected during transfer. Solid Edge handles the transfer of 3D section views the same as if the part was manually deleted from or added to the source assembly.

Sensors
Sensors are not maintained during part transfer. Solid Edge handles the transfer of sensors the same as if the part was manually deleted from or added to the source assembly.

Motion joints
Motion joints are not maintained during part transfer. Solid Edge handles the transfer of motion joints the same as if the part was manually deleted from or added to the source assembly.

Physical properties
Physical Properties are not maintained during part transfer. Solid Edge handles the transfer of physical properties the same as if the part was manually deleted from or added to the source assembly.

Dispersing subassemblies
You can use the Disperse command to disperse a subassembly by reassigning the parts to the next highest subassembly and removing the reference to the existing subassembly. The command will disperse only the top-level occurrence of a subassembly. For example, if a subassembly exists as an occurrence within the assembly being dispersed, the subassembly remains unchanged, but is moved up to the next higher assembly level.

The command does not modify the dispersed subassembly on the disk. The part occurrences are copied to the next higher level and the reference to the subassembly is deleted. When you save the top-level assembly, since it is no longer in the assembly structure, the dispersed subassembly occurrence is not saved.

If the subassembly being dispersed contains a pattern, the parts of the pattern are placed at the proper location in the next higher level and a ground constraint is placed on each of the parts. The
parts will not be grouped in the **PathFinder** under a pattern node, but will be ordered the same in the next higher assembly.

If you disperse a subassembly containing a tube part, the tube part and other parts are transferred to the next higher level, but the dispersed subassembly on the disk is not affected. Therefore, the tube part is still associative to the path when you open the subassembly stored on the disk.
Lesson 5: Activity: Transferring and dispersing in assembly
Activity: Transferring and dispersing assemblies

The objective of this activity is to demonstrate how the assembly structure can be altered without having to delete and replace parts and subassemblies manually.

In this activity you used the Disperse and Transfer commands to change the organizational structure of an assembly.
Open the assembly

- Open the assembly *Wheel_Base.asm* with all the parts active.
Examine the assembly structure

- In PathFinder, expand the subassemblies `right_rear_wheel_assembly.asm` and `left_rear_wheel_assembly.asm` as shown.

  ![Tree view of subassemblies](image)

**Note**

Notice an occurrence of the subassembly `tire_assembly.asm` is present in both `right_rear_wheel_assembly.asm` and `left_rear_wheel_assembly.asm`
Disperse one of the subassemblies

- In the subassembly `right_rear_wheel_assembly.asm` select `tire_assembly.asm` as shown.
Lesson 5: Activity: Transferring and dispersing in assembly

- Click the **Home tab→Modify group→Disperse** command.

  ![Image]

- If prompted: *The assembly that you are dispersing contains interpart relationships. If you continue, the interpart relationships could be broken. Continue?* Click Yes.

- When prompted: *Transfer the parts in the selected assembly to the next higher level, and delete the selected assembly occurrence?* Click Yes.

  **Note**

  When using **Inter-Part** relationships, the changes in one part can control the size and shape of geometry in another part. When changes are made to the parent part. If this type of behavior is still desired in the assembly after executing the disperse command, check to see if the links were broken. If they were, you will need to reestablish them.
Examine the results of the disperse command

- Compare the differences between `right_rear_wheel_assembly.asm` and `left_rear_wheel_assembly.asm`. Notice:
  - That `tire_assembly.asm` only exists in `left_rear_wheel_assembly.asm` now.
  - That the parts that once existed in `tire_assembly.asm` have been placed in the `right_rear_wheel_assembly.asm`.
  - The pattern that had four occurrences of `ASM_01_00601.asm` is no longer a pattern, and those four occurrences have been placed in `right_rear_wheel_assembly.asm`.
Transfer parts into a subassembly

- Select the parts `hub.par` and `shaft.par` in Assembly PathFinder.
- Right-click on the selection in PathFinder, and then click Show Only to hide the rest of the assembly.
- Click Fit to fit the view.
- Select the parts `hub.par` and `shaft.par` in Assembly PathFinder.
- Click the Home tab→Modify group→Transfer command.

**Note**
The Transfer command either moves the selected parts to a new location in the assembly structure, or combines the selected parts into a subassembly.

- Select the top level assembly, `Wheel_Base.asm`, as the destination for the subassembly being created, then click New Subassembly.
Name the new subassembly **hub_shaft_assembly.asm**. Direct the subassembly to the folder where the remainder of the assembly resides as shown. Then click **OK**.

View the destination of the new subassembly. If satisfactory, as shown, then click **OK**.

Notice the new subassembly consisting of the two selected parts in the **Assembly PathFinder**.
• Right-click on **Wheel_Base.asm** in **PathFinder** and then click **Show** to display the complete assembly, then **Fit** the view.

• Save and close the assembly. This completes the activity.
Summary

In this activity you learned the following

- How to move parts in a subassembly into a new location in the assembly structure with the **Disperse** command.

- How to create a new subassembly from parts within an assembly using the **Transfer** command, and how to locate the position in the assembly structure for the new subassembly to reside.
Lesson 6: Lesson review

Answer the following questions:

1. What does the Transfer command do in an assembly document?
2. What does the Disperse command do in an assembly document?
3. Can you disperse a subassembly?
Lesson 7: Lesson summary

In this lesson you learned the following

• How to move parts in a subassembly into a new location in the assembly structure with the **Disperse** command.

• How to create a new subassembly from parts within an assembly using the **Transfer** command, and how to locate the position in the assembly structure for the new subassembly to reside.
Lesson 8: Inter-Part

Overview

Creating parts in an assembly whose size and shape can be controlled based on the size and shape of geometry in another part in the assembly is accomplished through Inter-Part links. When the geometry of the parent part changes, the Inter-Part links in the linked part alter the geometry accordingly.
Lesson 9: Inter-Part associativity

When constructing the parts and assemblies for a design project, you can use the geometry on other parts in the assembly to help you construct a new part or subassembly. For example, you can use the Project to Sketch command to create 2D geometry for the base feature of a new part by copying edges on an existing part.

Depending on the approach you use, the included geometry can be associative or nonassociative to the original edges.

When you create new geometry associatively, then modify the original, or parent geometry; the child geometry also updates. If you change the size of the parent part, the included child geometry for the base feature also updates.

Note

- When designing in the context of an assembly, only ordered features can be linked using Inter-Part relationships. In the synchronous environment faces can be copied, but they are not linked to geometry contained in the part that the face was copied from.

- An Inter-Part Associativity tutorial is available that demonstrates how to create associative Inter-Part features.
The following commands and functions in Solid Edge allow you to use existing geometry associatively:

- **Project to Sketch** command
- **Inter-Part Copy** command
- **Assembly-Driven Part Features**
- **Reference Plane Definition**
- **Feature Extent Definition**
- **Variable Table**

**Note**

Many of these options are available only when you set the proper **Inter-Part** associativity option on the **Inter-Part** tab on the **Options** dialog box.

When one part is associatively linked to another part in Solid Edge, special symbols are used to indicate the associative link. For example, when you **Project to Sketch** an edge from another part in the assembly to define the profile for cutout feature in the active part, a link symbol is displayed adjacent to the part feature in **PathFinder** and adjacent to the part entry in **PathFinder**.

These associative links between parts are called **Inter-Part** links to indicate that one part is dependent on another part for the definition of some of its geometry. The link information is common to both parts, using the higher-level assembly to interpret the relative orientation of the geometry.

For more information about managing **Inter-Part** links, see the **Managing Inter-Parts Links** section of this Help topic.
Including elements

You can use the Project to Sketch command to include edges from the active part, an assembly sketch, or the other parts in the assembly. When including edges from an assembly sketch or another part in the assembly, you can control whether the included edges are associative to the parent element using the Inter-Part Locate options on the Project to Sketch dialog box.

You can only Project to Sketch elements from an assembly sketch or the other parts in an assembly when you are editing a part in the context of an assembly (you have in-place activated a part or you are creating a part in place).

When the Allow Locate of Peer Assembly Parts and Assembly Sketches option is set, you can locate and select elements in other parts and assembly sketches. To copy the elements associatively, you must also set the Maintain Associativity When Including Geometry From Other Parts in the Assembly option. When this option is cleared you can copy elements from other parts and assembly sketches nonassociatively.

Note

To include elements associatively between documents, set the Allow Inter-Part Links Using: Project to Sketch Command in Part and Assembly Sketches option on the Inter-Part on the Options dialog box.

Inter-Part copies

You can use the Inter-Part Copy command in the Part and Sheet Metal environments to associatively copy faces, features, and entire parts into another part document as construction geometry. You can then use the Project to Sketch command to associatively copy edges from the construction geometry into a profile for a feature. To ensure that the Project to Sketch command only copies edges from the associative construction geometry, turn off the assembly display using the Hide Previous Level command on the View tab.

The Inter-Part Copy command is only available when you are editing a part in the context of an assembly (you have in-place activated a part or you are creating a part in place).

Note

To copy elements associatively between documents, set the Allow Inter-Part Links Using: Inter-Part Copy Command option on the Inter-Part tab on the Options dialog box.

Note

Earlier versions of Solid Edge created a new link each time a piece of inter-part geometry was referenced. If the same Inter-Part geometry is referenced more than once in the local document, a single link is used. If that link is broken, all the children that use that link are affected. Freezing a link with multiple features referenced freezes all the children of the parent feature.
Assembly-Driven part features

You can use the assembly feature commands such as **Cutout**, **Hole**, and **Revolved Cutout** in the Assembly environment to construct assembly-driven part features in an assembly. You can specify which parts in the assembly you want to cut. **Assembly-Driven** part features are added as a linked feature to each part document.

For more information on **Assembly-Driven Part Features**, see the Assembly-based Features Help topic.

**Note**

To construct **Assembly-Driven Part Features** in an assembly, set the **Allow Inter-Part Links Using: Assembly-Driven Part Features** option on the **Inter-Part** tab on the **Options** dialog box.

Reference planes

When constructing a feature for a part, you can use an assembly reference plane to define the new feature. If the assembly reference plane is modified, the feature associatively updates. To select an assembly reference plane, press the **Shift** key, then select the assembly reference plane.

You can only use an assembly reference plane when you are editing a part in the context of an assembly (you have in-place activated a part or you are creating a part in place).

**Note**

To use an assembly reference plane while constructing a part feature, set the **Allow Inter-Part Links Using: Assembly Reference Planes In Feature** option on the **Inter-Part** tab on the **Options** dialog box.
**Feature extents**

When working within the context of an assembly, many feature commands allow you to select a keypoint on another part in the assembly to define the extent for a feature. For example, when constructing a protrusion in the Part environment, you can select a keypoint (A) on another part in the assembly during the Extent Step.

The extent for the feature is associative to the keypoint on the part you select. If the other part is modified (B) such that the keypoint location changes, the extent for the linked feature also updates.

You can also use an assembly sketch to define the extent for a feature.

**Variables**

You can use the Variable Table in Solid Edge to associatively paste an assembly variable into a part or subassembly. This allows you to control several parts at once with one variable. For example, you can create an assembly variable to control the size of a hole in several parts in the assembly.

For more information on pasting variables between documents, see the Linking Variables Between Parts in an Assembly section of the Variables Help topic.

**Note**

To associatively paste variables between documents, set the Allow Inter-Part Links Using: Paste Link To Variable Table option on the Inter-Part tab on the Options dialog box.
Lesson 10: Activity: Inter-part assembly modeling
Activity: Inter-Part assembly modeling

When you complete this activity, you will be able to use Inter-Part modeling techniques to create new parts in an assembly.

For this activity, you will model a mating cover for the sheet metal chassis shown in the following illustration. The activity emphasizes the use of Inter-Part modeling in Solid Edge Assembly. Inter-Part enables the modeling and mating of parts within an assembly to maintain like design characteristics between the parts. In other words, when one part is changed, the mating parts change accordingly. This is a top-down assembly modeling method.

Activity guides you through the process of associatively linking parts with Inter-Part copies, so that changes in one part will be reflected in another part.
Create a new assembly file and set the parameters for Inter-Part

- Create a new metric assembly file.
- Hide all the assembly reference planes if they are shown.
- To allow Inter-Part links using Inter-Part copy, set the option in the Solid Edge Options dialog box. Click the Application button. Click Settings→Options. Click the Inter-Part tab, and select the options as shown. Click OK.

![Options dialog box]

- Insert a part into the assembly. This part will be used as a reference part to construct the mating cover. On the Home tab in the Assemble group, click Insert Component. In Parts Library tab, drag Chassis.psm into the main assembly window.

- Save the file as interpartassy.asm in the folder being used for the activity.
Create a new part in-place

- Click the Home→Assemble→Create Part In-Place command. Fill out the Create New Part In-Place dialog box as shown, and then click Create and Edit. Make sure the template option is set to the sheet metal template, iso metric sheet metal.psm. The name of the new part will be cover.psm. The Coincident with assembly origin option assures proper orientation of the new part. Make sure the folder for the New File Location is the folder containing the activity files.
• On the Application menu, choose Info→Material Table. Set the gage to 20, then click Apply to Model.
Insert an Inter-Part Copy that will be used as a construction surface to create a sheet metal cover

- Right-click in PathFinder and then click Transition to Ordered.

- Click Home→Clipboard→Inter-part Copy.

- Click Chassis.psm as the assembly part to copy from, and then select the thickness face as shown.

- Click the Accept button and then click Finish. This face serves as a construction surface within the sheet metal part file.
To turn off the display of **Chassis.psm**, click **View→Show→Hide Previous Level**. Ensure the base reference planes are shown.

**Note**

When you select a part for modification (in-place activation) through the **Edit** command within an assembly, **Hide Previous Level** turns off the display of the remaining parts within the assembly for the sake of clarity.

Ensure the base reference planes are shown.
Use the Contour Flange command to construct the sheet metal cover

Note
The modeling strategy for this activity is to use the construction surface to control the size and shape of the cover. PathFinder shows the thickness face as a construction surface. Constructions will need to be displayed in PathFinder to see the linked Inter-Part Copy.

- Click the Contour Flange command. Select the reference plane as shown.
- Draw the profile as shown. Dimension and constrain the left side the same as shown for the right side. Apply a Horizontal/Vertical relationship as shown (A). Click Close Sketch.

- Click outside the profile to accept the side step as shown.
Click the **Symmetric Extent** button, and then select any key point on the construction surface for the cover extent. Click **Finish** to complete the cover.

**Note**

The new cover is now in place. If an edit is made to **Chassis.psm** (from which the construction surface was copied), the new cover will update when the update links button is clicked, and then the construction surface will update. You will do this later in the activity.

Click **View→Show→Hide Previous Level**. This turns on the display of **Chassis.psm**.

**Hide** the reference planes.

Save, but do not exit the file. Click **Yes** if you see the dialog box shown.
Place a cutout and four holes on the top face of the cover linked via Inter-part

- Click **Home→Clipboard→Inter-part Copy**. Copy the four top faces of the tabs as shown.

- Click **View→Show→Hide Previous Level** to turn off the display of **Chassis.psm**. The cover and the four copied faces display.
Place four holes on the cover using the inter-part copied faces as reference

- Click the **Home→Sheet Metal→Hole** command.

- Highlight the top face of the sheet metal cover for the reference plane and orient the plane as shown. Press **N** to toggle reference plane orientations, then click to select this orientation.

- Click the **Hole Options** button.
• Set the options as shown.
- Place four **6.35 mm** Simple holes centered on the circles of each **Inter-Part Copy** face as shown.

- Close the sketch, then click **Finish**.

- In **PathFinder**, turn off the surfaces created by **Inter-Part Copy**.

- Save the file. The result is shown.
Add a cutout to the cover

> Click the **Home→Sheet Metal→Hole→Cut**.

> Select the top face of the sheet metal cover for the reference plane and orient as shown.

> Draw the profile for the cutout as shown.

> Click **Close Sketch**.
• Click **Through Next** and position the arrow as shown.

![Diagram](image1)

• Click **Finish**.

![Diagram](image2)

• Save the file.
Turn on the display of Chassis.psm and then return to the assembly file

- Click Hide Previous Level to turn on the display of Chassis.psm. The two-part assembly displays.

- Click Close and Return. This returns you to the assembly.
Make an edit and update the links to update the new sheet metal cover

**Note**
Edits to dimensions can be done at the assembly level for assembly components containing ordered geometry.

- On the **Home** tab in the **Select** group, set the **Select Priority** to **Face Priority**.

- Select **Chassis.psm**, then click **Dynamic Edit**.
Select the following dimensions and edit their values:

- 200 mm (part length) to 250 mm.
- 50 mm (part height) to 75 mm.

If the cover has not updated at this time, click **Tools→Update→Update All Open Documents** to force the update.

Repeat the editing procedure, and change dimensions on **Chassis.psm** back to their original values:

- 250 mm (part length) to 200 mm.
- 75 mm (part height) to 50 mm.

Save the file. This completes the activity.
Activity Summary

In this activity you learned how to use the create in place command to create a new sheet metal file in the context of an existing assembly. **Inter-Part** functionality was used to link geometry in the new sheet metal file to geometry in other files in the assembly. You learned that because the faces used to create the new sheet metal file were linked to the other parts of the assembly, changes made to those other parts result in a change of size and shape of the new part, which responds to the changes made via the **inter-part** link.
Lesson 11: Lesson review

Answer the following questions:

1. Name the two methods of building an assembly in Solid Edge.
2. Describe the bottom up approach to assembly modeling.
3. Describe the top down approach to assembly modeling.
4. Is it possible to combine top down and bottom up assembly modeling?
5. Describe the use of the Project to Sketch command when using the top down assembly modeling approach.
Lesson 12: Lesson summary

In this lesson you learned how to use the create in place command to create a new sheet metal file in the context of an existing assembly. **Inter-Part** functionality was used to link geometry in the new sheet metal file to geometry in other files in the assembly. You learned that because the faces used to create the new sheet metal file were linked to the other parts of the assembly, changes made to those other parts result in a change of size and shape of the new part, which responds to the changes made via the **inter-part** link.
Lesson 13: Assembly layouts

As you develop the design concepts for a new assembly, it is useful to create a layout of the preliminary design. The Sketch command in the Assembly environment allows you to draw 2D sketch geometry on part or assembly reference planes.

You can draw assembly sketches on the three default assembly reference planes or you can create new assembly reference planes to draw sketches on.

You can use assembly sketches to do the following:

- Create 3D ordered geometry within parts.
- Create assembly features.
- Position 3D parts relative to the sketch geometry.
- Position an assembly sketch relative to a 3D part.

For information about how you can use sketches in your assemblies, see Using sketches in assemblies.

Positioning 3D components using assembly sketches

You can position parts and subassemblies with respect to a part or assembly sketch. You can position 3D components using assembly relationships, such as mate and planar align; or using 2D dimensions and relationships, such as distance between and connect, or using the Select command.

While editing an assembly sketch, you can use the Parts Library tab to add new components to the assembly.

Positioning 3D components using assembly relationships

You can use assembly relationships, such as Mate, Planar Align, Connect and Axial Align, to position a part to a keypoint or a line on a part, subassembly, or top-level assembly sketch.
Example

It can be difficult to position a bolt in a slot using faces. In this example, a bolt part is positioned to a point element on a part sketch. An inferred axis that is perpendicular to the reference plane of the sketch on which the point lies defines the axis for the **Axial Align** relationship. The arc and point were drawn such that if the size or position of the slot changes, the arc and point will also update properly.

Positioning 3D components using 2D dimensions and relationships

While you are editing an assembly sketch, you can use 2D dimensions and relationships to position a 3D component relative to elements in the sketch. When you edit the assembly sketch, the position of the roller parts update. This can be useful when creating a new assembly that uses existing components.

Example

You can use connect relationships (A) to position roller parts (B) relative to an assembly sketch.

In this example the value of the 60 millimeter dimension was edited in the assembly sketch to 75 millimeters. Because the roller part was constrained to the assembly sketch using a 2D connect relationship, the position of the roller updated when the sketch dimension was edited.
Positioning 3D components using the Duplicate Component command

In an assembly layout sketch, you can reference and position components defined as blocks using the **Duplicate Component** command. Using the **Select From** and **Select To** steps in the command, you can select a block in an assembly or subassembly sketch, which is then matched to the orientation of the components.

Positioning 3D components using Select

When a sketch window is active, you can use the **Select** command and options on the Position 3D Component command bar to specify whether the sketch drives the position of the 3D component or the 3D component drives the position of the sketch. In the previous example, the **Sketch Driving** option was set for the roller parts to specify that the sketch drives the position of the 3D components.
Note

When you set the **Sketch Driving** option, the component symbol in **PathFinder** indicates that the component is driven by the assembly sketch.

You can use the **Select** command to select the 3D component in **PathFinder** or you can use the Component Select Tool command to select the 3D component in the graphics window.

As you choose which relationships and techniques to use when you position components in assemblies, keep in mind the following:

- That you cannot use 2D dimensions and relationships to position 3D components that conflict with existing 3D relationships.

- When you set the **Sketch Driving** option for a part, it is with respect to the current sketch. If relationships are available, the part can be driven by or drive another sketch.

- You can set the **Sketch Driving** option for a part in more than one sketch and apply 2D relationships in each sketch until the part is fully positioned. This can make it easy to fully position a part using two or more sketches.

- When you set the **Lock Alignment** option on the **Position 3D Component** command bar, the part is locked parallel with respect to the sketch plane and the part face you selected. The part can still move and rotate. This can make it easy to fully position a part using one sketch.

**Positioning assembly sketches using 3D components**

You can also constrain elements on an assembly sketch to a 3D assembly component such that if the size, shape or position of the 3D component changes, the assembly sketch updates. When you are editing an assembly sketch, you can select a 3D component and set the **Component Driving** option on the **Position 3D Component** command bar to specify that the 3D component drives the size, shape, and position of the assembly sketch.

**Assembly sketches and alternate assemblies**

The **Sketch** and **Copy Sketch** commands are available only when the **Apply Edits to All Members** option on the **Alternate Assemblies** tab is set (you are working globally).

For more information, see the Alternate Assemblies Impact on Solid Edge Functionality Help topic.
Lesson 14: Assembly layout overview

Overview

Creating parts in an assembly whose size and shape can be controlled based on the size and shape of geometry in a sketch in the assembly is accomplished through Inter-Part links. When the geometry of the sketch changes, the Inter-Part links in the linked part alter the geometry accordingly.
Lesson 15: Activity: Creating parts from Assembly Sketches
Activity: Layout sketches in assembly

When you complete this activity, you will be able to use Inter-Part modeling techniques to create new parts in an assembly using sketch geometry in the top level assembly.

For this activity, you will use sketch geometry to control the size and shape of two halves of a radio housing.

Activity guides you through the process of associatively linking parts with Inter-Part links to sketch geometry, so that changes in the sketch will be reflected in the parts in the assembly.
Set associativity parameters

Set the parameters needed to have the sketch control the geometry of the parts created in the assembly.

- Open radio.asm located in the folder where you placed your activity files.

- Click the Application button, then click Settings→Options. In the Solid Edge Options dialog box, click the Inter-Part tab. Select the options as shown and click OK.

![Checkboxes for Inter-Part settings]

**Note**

For this activity, an assembly sketch is provided. This sketch will be used to drive the creation of two parts that make up the front and back of a radio housing.
Create a part that is the front half of the radio housing

Create a part that is the front-half of the radio housing.

- Click **Home**→**Assemble**→**Create Part In-Place**.

- Type the new part file name as **front.par**. The new file location will be the same location as the current assembly. Click **Create** and **Edit**. **Solid Edge** opens the new part file and displays the sketch contained in the assembly file **radio.asm**.
Construct an extrusion

Construct an extrusion using the assembly sketch.

- If you are in the Synchronous environment, right-click in PathFinder and then click Transition to Ordered.

- In PathFinder, display the base reference planes.

- Click the Extrude command.

- Select the reference plane shown.

- Click the Project to Sketch command.
In the **Project to Sketch Options** dialog box, make the selections as shown. Any elements you select to include will link to the assembly sketch for associative edits. Click **OK**.

In the command bar, set the select box to **Wireframe Chain**.

Select the sketch chain shown.

Click the **Accept** button and then **Close Sketch**.
• Type 15 for the **Finite Extent** distance and select the extent direction shown.

• Click **Finish**.

• In Feature **PathFinder**, turn off all reference planes in the current part file. The reference planes and sketch from the assembly file continue to display.

• Click **View→Show→Hide Previous Level**. This turns off the display of the reference planes and the sketch.
Add a round

Add a round to an edge of the part.

- Click the **Round** command.

- Select the edge shown.

- Type 3 for the radius and click the **Accept** button.

- Click **Preview** and then **Finish**.
Apply a thickness to the part

Apply a thickness to the part using the Thin Wall command.

- Click the Thin Wall command.
  
  ![Thin Wall command](image)

- Type 3 for the common thickness. Select the face shown to be the open face.

  ![Part with thin wall](image)

- Click Preview and then Finish. In the image below, the part was rotated 180° to show the thin wall feature.

  ![Part rotated 180°](image)
Add cutouts

Add several cutout features to the part in one step.

- Click the **Cut** command.
- Click **View→Show→Hide Previous Level**. This turns the display of the reference planes and the sketch back on again.

- Select the front face as the profile plane as shown.
• Click the **Project to Sketch** command. Set the options as shown and click **OK**.

![Project to Sketch Options](image)

• Set the select field to **Wireframe Chain**.

• Select the five chain sets shown and click the **Accept** button. Click **Close Sketch**.

![Sketch Diagram](image)
Lesson 15: Activity: Creating parts from Assembly Sketches

- Select the **Through Next** option for the extent. Set the direction as shown and click **Finish**.

The front part is now complete.

- Click the **Home** tab. Click **Close and Return** to return to the assembly file **radio.asm**.
Click the **Assembly PathFinder** tab and notice that the part just created is now a part of the assembly.
Create the back half of the radio housing

Create the back-half of the radio housing.

- Click Home→Assemble→Create Part In-Place.

- Type the new part file name as back.par. The new file location will be the same location as the current assembly. Click Create and Edit. Solid Edge opens the new part file and displays the sketch contained in the assembly file radio.asm.
Construct a protrusion using the assembly sketch

Construct a protrusion using the assembly sketch.

▸ If you are in the Synchronous environment, right-click in PathFinder and then click Transition to Ordered.

▸ In PathFinder, display the base reference planes.

▸ Click the Extrude command.

▸ Select the reference plane shown.
Click the **Project to Sketch** command. In the **Project to Sketch Options** dialog box, make the selections as shown. Any elements you select to include will link to the assembly sketch for associative edits. Click **OK**.

![Project to Sketch Options dialog box]

- Set the select field to **Wireframe Chain**.
- Select the outside wireframe chain as shown. Click the **Accept** button and then click **Close Sketch**.

![Selecting the wireframe chain]

Click the **Project to Sketch** command. In the **Project to Sketch Options** dialog box, make the selections as shown. Any elements you select to include will link to the assembly sketch for associative edits. Click **OK**.

![Project to Sketch Options dialog box]

- Set the select field to **Wireframe Chain**.
- Select the outside wireframe chain as shown. Click the **Accept** button and then click **Close Sketch**.
• Use the **Finite Extent** and type **12** for the distance. Set the direction as shown and click **Finish**.

• Click **View→Show→Hide Previous Level**.
Add a cutout to the part

Add a cutout to the part.

- Click the **Cut** command.
- Select the face shown for the profile plane.

- Draw and dimension the profile as shown. Click **Close Sketch**.

[Diagram showing dimensions and angle]
• Position the arrow as shown and click for direction of material removal.

• Select the **Through All Extent** option and set the direction arrow to both directions as shown and click.
- Click **Finish**.

**Note**

The view was rotated 180° for the image below.
Thin wall the part
Apply thickness to the part using the **Thin Wall** command.

- Click the **Thin Wall** command.
- On the command bar, type 3 for the common thickness.
- Select the face shown as the open face. **Click Preview** and then **Finish**.
Add another cutout

Add another cutout using elements from the assembly sketch.

▸ Click the **Cut** command.

▸ Click **View→Show→Hide Previous Level**.

▸ Select the face shown for the profile plane.

▸ Click the **Project to Sketch** command. Click **OK** in the dialog box.

▸ On the command bar, set the Select field to **Wireframe Chain**.
• Select the wireframe chain as shown and click the **Accept** button. Click **Close Sketch**.

![Diagram](image1)

• Click the **Through Next Extent** option. Set the extent direction as shown and click.

![Diagram](image2)
Click Finish.

The back part is now complete.

Click Close and Return to return to the assembly file radio.asm.

Click the Assembly PathFinder tab and notice that the part just created is now a part of the assembly.
Edit the assembly sketch and observe changes

Now that two parts are created that are driven by the assembly sketch, edit the assembly sketch to observe how the two parts update to the sketch changes.

- Click the **Select Tool**.

- In **Assembly PathFinder**, click the assembly sketch named **Sketch_1**.

- Click the **Edit Definition** button.

- Click the **Draw Profile** step in the command bar.

- Edit the dimensions as shown.
  
  \[
  \begin{align*}
  A &= 80 \\
  B &= 140 \\
  C &= 30 \\
  D &= 30
  \end{align*}
  \]
> Click **Close Sketch**. Click **Finish**, and notice how the assembly parts update to the changes made to the assembly sketch dimensions.
**Repeat the previous step**

Repeat the previous step to make the following changes to the assembly sketch.

- Edit the dimensions as shown.
  
  \[
  \begin{align*}
  A &= 90 \\
  B &= 60 \\
  C &= 25
  \end{align*}
  \]

- Click **Close**. Click **Finish** to update the assembly parts.
Link the wall thickness to the two parts

The final step in the activity is to link the wall thickness variables of the two parts. This will ensure that if a change is made to the wall thickness that both parts will update simultaneously. Use peer variables to accomplish this.

- Click **Tools→Variables→Peer Variables**.

- Click **front.par** in the assembly window. A variable table for the selected part displays. To display the dimensions and variables, click the **Filter** button. Click dimensions and user variables in the type: field and select the radio button for both as shown. Click **OK**.
Click the left-most button on the **Thinwall_1_Thickness** variable and then right-click (the variable name may differ slightly). Select **Copy Link** as shown.

![Copy Link screenshot](image1)

Click **back.par** in the assembly window. A variable table for the selected part displays.

![Variable table screenshot](image2)

Click the left-most button on **Thinwall_3_Thickness** variable and then right-click (the variable name may differ slightly). Select **Paste Link**.

![Paste Link screenshot](image3)

Notice the link placed in the formula field for the wall thickness variable for **back.par**. If the wall thickness is edited in **front.par**, **back.par** updates automatically to same wall thickness value.

![Variable table screenshot](image4)

Click **Close** to dismiss the variable table.
This completes this activity.
Activity summary

In this activity, you learned how to use assembly sketches to create and control the size and shape of parts created in a top down design. Inter-part links between the assembly geometry and the part features were used to control the part features from the assembly sketch. Variables from the assembly can be linked to variables in part files to link dimensions and control geometric behavior as the dimensions change.
Lesson 16:  Lesson review

Answer the following questions:

1. What is an assembly layout sketch?

2. What command is used to create a new part or sheet metal document from within the context of an assembly?

3. When will changing the size and shape of geometry in a layout sketch change the size and shape of part or sheet metal components within an assembly?
Lesson 17: Lesson summary

In this lesson, you learned how to use assembly sketches to create and control the size and shape of parts created in a top down design. Inter-Part links between the assembly geometry and the part features were used to control the part features from the assembly sketch. Variables from the assembly can be linked to variables in part files to link dimensions and control geometric behavior as the dimensions change.
Siemens Industry Software

Headquarters
Granite Park One
5800 Granite Parkway
Suite 600
Plano, TX 75024
USA
+1 972 987 3000

Americas
Granite Park One
5800 Granite Parkway
Suite 600
Plano, TX 75024
USA
+1 314 264 8499

Europe
Stephenson House
Sir William Siemens Square
Frimley, Camberley
Surrey, GU16 8QD
+44 (0) 1276 413200

Asia-Pacific
Suites 4301-4302, 43/F
AIA Kowloon Tower, Landmark East
100 How Ming Street
Kwun Tong, Kowloon
Hong Kong
+852 2230 3308

About Siemens PLM Software

Siemens PLM Software, a business unit of the Siemens Industry Automation Division, is a leading global provider of product lifecycle management (PLM) software and services with 7 million licensed seats and 71,000 customers worldwide. Headquartered in Plano, Texas, Siemens PLM Software works collaboratively with companies to deliver open solutions that help them turn more ideas into successful products. For more information on Siemens PLM Software products and services, visit www.siemens.com/plm.

© 2017 Siemens Product Lifecycle Management Software Inc. Siemens and the Siemens logo are registered trademarks of Siemens AG. D-Cubed, Femap, Geolus, GO PLM, I-deas, Insight, JT, NX, Parasolid, Solid Edge, Teamcenter, Tecnomatix and Velocity Series are trademarks or registered trademarks of Siemens Product Lifecycle Management Software Inc. or its subsidiaries in the United States and in other countries. All other trademarks, registered trademarks or service marks belong to their respective holders.